解决:Error:'com.android.build.gradle.BasePlugin' does not implement the Plugin interface

2016/07/27
Error:'com.android.build.gradle.BasePlugin' does not implement the Plugin interface.  

导入Ionic工程到AndroidStudio中的时候,出现了上面这个错误。

这是由于升级gradle版本造成的。解决的办法很简单是,将项目的 build.gradle 文件中的

 if (gradle.gradleVersion >= "2.2") {  
    dependencies {  
        classpath 'com.android.tools.build:gradle:1.5.0'  
    }  
} else if (gradle.gradleVersion >= "2.1") {  
    dependencies {  
        classpath 'com.android.tools.build:gradle:0.14.0+'  
    }  
} else {  
    dependencies {  
        classpath 'com.android.tools.build:gradle:0.12.0+'  
    }  
}  

修改为

if (gradle.gradleVersion >= "2.2") {  
    dependencies {  
        classpath 'com.android.tools.build:gradle:1.5.0'  
    }  
} else if (gradle.gradleVersion >= "2.1") {  
    dependencies {  
        classpath 'com.android.tools.build:gradle:2.1.0'  
    }  
} else {  
    dependencies {  
        classpath 'com.android.tools.build:gradle:0.12.0+'  
    }  
}  

此时,如果 classpath 'com.android.tools.build:gradle:0.12.0+' 这一行报错,或者有条红色的下划线,那么可以将这行换成

classpath 'com.android.tools.build:gradle:2.1.0'

正常情况下,项目应该是可以正常编译了。


如果此时仍然报错:

Error:(53, 0) Cannot create task of type 'Wrapper' as it does not implement the Task interface.  

解决的办法是在项目的build.gradle 文件中删掉下面的代码:

task wrapper(type: java.sql.Wrapper) {  
    gradleVersion = '2.2.1'  
}